Amtrak app

Help Support Amtrak Unlimited Discussion Forum:

Tom Booth

Service Attendant
Joined
Jul 5, 2019
Messages
156
I have yet another problem after being off line. My iPhone 5C will not update the Amtrak app. I tried to delete and reinstall but evidently the 5C is too old a version. That's fine but I can't even use the older Amtrak app version. I know the phone is ancient - all of 5 years old!!!!! - but is this the way it is now? I have a number of friends now with the same problem. Are we all just Luddites?
 

AmtrakBlue

Conductor
Gathering Team Member
Joined
May 6, 2011
Messages
11,685
The admins of AU discontinued the app :( You'll need to use the mobile web version.
 

Tom Booth

Service Attendant
Joined
Jul 5, 2019
Messages
156
The admins of AU discontinued the app :( You'll need to use the mobile web version.
Thanks for the quick reply. This is true of the official Amtrak app for ticketing etc.? And if my iPhone is too old I,m out of luck? Because it wouldn't upload the newer version.
 

AmtrakBlue

Conductor
Gathering Team Member
Joined
May 6, 2011
Messages
11,685
Thanks for the quick reply. This is true of the official Amtrak app for ticketing etc.? And if my iPhone is too old I,m out of luck? Because it wouldn't upload the newer version.
Sorry, my bad. I was thinking of the AU app, not Amtrak's app. I have no problem using Amtrak's app.
 

printman2000

Conductor
Joined
Nov 9, 2005
Messages
3,753
Since the 5c can not load current iOS versions, it probably can not load the latest Amtrak app. And they have probably changed things so much even old versions will not work.
While you may have bout yours 5 years ago, it was released in 2013!
 

chakk

Conductor
Joined
May 26, 2011
Messages
2,555
My luddite sister-in-law purchased an iPhone SE last month and is now VERY happy she did. Before that, she was using a non-smart cell phone that probably was at least a decade old.
 
Joined
Jun 30, 2020
Messages
12
I have yet another problem after being off line. My iPhone 5C will not update the Amtrak app. I tried to delete and reinstall but evidently the 5C is too old a version. That's fine but I can't even use the older Amtrak app version. I know the phone is ancient - all of 5 years old!!!!! - but is this the way it is now? I have a number of friends now with the same problem. Are we all just Luddites?
What version of iOS are you using? (To check it open Settings> General > About > Software Version) For example the current version I'm using is 13.5.1. If your software is up-to-date you should be able to use the Amtrak app.
 
Top